Dynamically created datapipeline names not saving in report template

edited June 2001 in General

I am using Delphi 5 with Report Builder Enterprise 5.56 and I am having a
problem. The problem is that I create all my datapiplines dynamically for
each report, but I also allow users to edit and save the report. But when
you save the report it doesn't include the name of the pipeline that was
being used. I have tested this and it seems to only save the pipelines name
if the datapipline was added to the form in the designer and not created at
run time. Is this a standard feature of the way that Report Builder saves
the reports or is there a way around this.

Any help would be gratefully received


James Yule
Rosetta Media Ltd


  • edited June 2001

    1. Make sure that when you create the datapipeline the Owner is the same
    as the Owner of the Report.

    2. For testing purposes, set Report.Template.Format to ftASCII. Then
    save the report and open the .rtm file in the Delphi editor or notepad.

    RB uses standard Delphi VCL object streaming. DataPipeline is a
    published property of Report and therefore the name of the pipeline
    object reference is saved. However, Delphi expects all of the objects to
    have the same Owner. The only exception to this would be DataModules.

    Best regards,

    Nard Moseley
    Digital Metaphors
  • edited June 2001

    Thanks for your reply, it turned out that I was not setting the name of the
    pipeline just the user name and without a name it has nothing to save.

    How stupid do I feel



This discussion has been closed.