New Blog Post: RESTful Reporting

Data tab disappeared - urgent!

Hi

I am using an old version of Report builder enterprise in a legacy Delphi 7 application.

After a recent upgrade to the application an end user noticed that the Data tab in the Report builder interface was missing. I checked that the previous version of the application had this working and did a git diff of the delphi form with the ReportBuilder components / report browser. There was almost no changes and in any case I tried reverting these and it makes no difference.

I have reinstalled Report Builder and also DBISAM but still the Data tab (and also the 'Calc' tab) is not showing . I get no error messages and it is unclear to me how I go about diagnosing the problem.

The version that worked used the same version of DBISAM as currently used. There are no code changes around DEFINES etc

ReportBuilder version is 11

Any suggestions on how to diagnose this urgently needed and gratefully received - my end users are understandably upset that I shipped an upgrade with a broken report engine!

Comments

  • Sorry to clutter the forum. This problem is now fixed. I had not been looking long enough back in git for changes that broke my code. Am not entirely sure, but I think cnwizards 'clean uses' tool caused the problem. Working now.
Sign In or Register to comment.