ReportBuilder v20 Installation fails in Tokyo 10.2

After completing the installation of version 20.0 in Tokyo 10.2, when trying to open Tokyo 10.2 it fails to try to load the BPL files.

Comments

  • Hi Julio,

    What is the specific error message you are receiving? What RB version did you have installed before? Please provide details.

    I performed a test install of RB 20 Enterprise for Tokyo 10.2 and it worked correctly.



    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • I've downloaded and installed RB 20.0 (19.04 was previously installed) and now when I start the Delphi IDE I get a small dialog box that pops up saying "The procedure Entry Point @System@Net@Httpclient@Win@TWinHttpLib@$bcctr$qqrv could no be locate in the dynamic link library c:\WINDOWS\SYSTEM32\rbIDE2025.bpl"

    he also does it with the other library: rbCT2025.bpl, rbDB2025.bpl, etc.

    Rebooting the PC makes no difference.

    Delphi 10.2, Windows 10

    What else would you like to know?
  • I encountered the same problem. Would like to know if there is a resolution or workaraound.
  • After researching this, it is our understanding that Delphi 10.2 Update 3 is required to successfully use ReportBuilder 20. Please be sure to have Update 3 installed before installing ReportBuilder 20 to avoid these issues.

    Our website has been updated to reflect these requirements.




    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • Hello, this is a new requirement that arises after showing you the difficulties to install in that version. I think it should be somewhat obvious to you that if we are using Tokyo and not Rio is for some reason, we have no subscription for the latest versions of Delphi. To consider myself as a solution to upgrade to delphi update 3 is to send me to buy the latest version of delphi, which is not currently in budget. If the 19.04 version works perfectly in the version we currently have because they did not do the same with the 20.00 version, the solution that you offer me is not feasible for me, so I do not accept it as a solution.

    Regards
  • Julio,

    I'm very sorry but it is absolutely necessary for us to build our products with the latest version(s) of Delphi. It is the responsibility of Embarcadero to keep their minor updates backward compatible. In this particular case, it does not appear they did.

    RB 19 functions correctly because it does not include some of the new features that were added for version 20. We strive to continually move the ReportBuilder product forward and in doing so will utilize many new Delphi features along the way. One of these features has clearly caused an incompatibility with earlier, outdated releases of Delphi 10.2.

    As you can see from the link below, we are not the only third-party tool with this issue.
    https://www.steema.com/support/viewtopic.php?t=16775

    Please consider updating your version of Delphi in order to use ReportBuilder 20. If you would like to discuss this further, please email us at support@digital-metaphors.com.



    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
This discussion has been closed.