Email Report missing attachment

Hi there

I am using SMTP to send reports to recipients but sometimes the attachment is missing. IS there a way to see what could be causing this ? image here you can see 4 emails sent from Report Builder , 2 have attachments and the other 2 none.

Thanks in advance

Comments

  • Hi Oliver,

    Which version of ReportBuilder are you currently using? Are you streaming the attachments?

    As a test, try setting the EmailSettings.DeleteFile property to False, and then verify that the PDF file is actually being created before emailing.


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited November 2020
    Hi Nico

    Thanks for the reply.

    On this application , we are using ReportBuilder Enterprise Edition Version 16.02 Build 144 on Delphi XE5.

    I am setting these settings to allow the user to email the report from the print preview. In this case the customer is using the SMTPIndy Option
    with (sender as TppReport) do begin
           EmailSettings.Enabled := true;
           AllowPrinttoFile := true;
           printersetup.Duplex := dpNone;
    
    
    
           try
             smtpsettings.close;
             smtpsettings.open;
             if SMTPSettingsSMTP_REPORTBUILDER.asinteger = 1 then begin
                   EmailSettings.PreviewInEmailClient := false;
                   EmailSettings.Showemaildialog := true;
                   EmailSettings.FromAddress := SMTPSettingsFROM_ADDRESS.asstring;
                   EmailSettings.ReplyTo := SMTPSettingsFROM_ADDRESS.asstring;
                   EmailSettings.FromName := SMTPSettingsFROM_NAME.asstring;
                   EmailSettings.HostAddress := SMTPSettingsSMTP_SERVER.asstring;
                   EmailSettings.UserName := SMTPSettingsSMTP_USEr_ID.asstring;
                   EmailSettings.Password := SMTPSettingsSMTP_PASSWORD.asstring;
                   EmailSettings.Subject := '';
    
                   TppSMTPPlugIn.RegisterClass(TppSMTPIndy)
             end
             else begin
               EmailSettings.PreviewInEmailClient := true;
               EmailSettings.Showemaildialog := false;
               TppSMTPPlugIn.RegisterClass(TppSMTPMapi);
             end;
             smtpsettings.close;
           except
              EmailSettings.PreviewInEmailClient := true;
              EmailSettings.Showemaildialog := false;
              TppSMTPPlugIn.RegisterClass(TppSMTPMapi);
           end;
    
    
        end;
    I have tried your recommendation and am awaiting feedback from the user.

    Regards
    Oliver
Sign In or Register to comment.