New Blog Post: PDF/A and Metadata

Runtime Error - TdaSQLQueryDataview not found

edited May 2011 in End User
I'm having more trouble with my End User app.

At runtime, when trying to preview a Report, I'm getting

"... Class TdaSQLQueryDataView not found" .

Delphi XE Update 1 and RBuilder 12.4.

I've recompiled the daDBExpress dcu as per a couple of posts above.

Help Nico :-)

Rob

Comments

  • edited May 2011
    Hi Rob,

    The TdaSQLQueryDataView class should be in the daDBExpress unit. If
    this unit is added to your uses clause, Delphi should be able to find
    that class.


    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited May 2011
    Thanks for the reply Nico.

    Yes, daDBExpress is in the Uses Clause (interface), and the application
    compiles successfully.

    The problem is, at runtime, in the Report Explorer, when attempting to
    preview or open a report, I'm getting a error dialogue


    Class TdaSQLQueryDataView not found
    Ignore the error and continue?



    I was wondering if this may be related to the problem of RBuilder 12.04
    running/compiling on Delphi XE Update 1. If you think that's unlikely,
    I'll look further for the cause :-).

    Thanks again

    Rob

  • edited May 2011
    Hi Rob,

    I just tested the DBExpress demo for Interbase with Delphi XE Update 1
    and everything worked as expected. Are you able to run the demo on your
    machine? If so, give me the steps I need to take to recreate the issue.
    I am currently able to open, create, save, reopen any report without
    error.


    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited May 2011
    Hi Nico - thanks for taking the time to look at this.

    I've got meetings all day today - but will set up a test environment
    tomorrow (with Interbase installed) and see if I can resolve it.

    As you have it running the problem doesn't appear to be a version issue
    (good to know).

    I'll report back when I have more info.

    Cheers

    Rob

  • edited May 2011
    Update

    Nico, I remembered that my DEV Machine (Machine A) has RAD Studio XE
    Hotfixes 280864 and 280988 applied.

    I did some testing.

    I ran up a VM (Win7 Ent, RAD Studio XE, Update 1, RBuilder 12.4)
    Machine B.

    Here's what I found after some digging (both machines have
    daDBExpress.pas copied to the Lib folder).

    On Machine B, in the Object Inspector for the ppDesigner, I see Session
    Types of :

    dbExpressSession
    ADOSession
    BDESession.

    The app executes just fine and I can run and preview reports.

    On Machine B, in the Object Inspector for the ppDesigner, I see Session
    Types of :

    ADOSession
    BDESession
    Missing dbExpressSession.

    The app compiles and runs, BUT when trying to preview a report I get

    "daSQLQueryDataView not found"

    Now I'm NOT saying the hotfixes are the cause here - other factors may
    have changed that I'm not aware of. Anyhow, it may be useful info for
    you guys when you're testing a new release.

    Bottom line is I now have somewhere I can get a working compile - so
    I'm happy.

    Cheers Nico

    Rob
  • edited May 2011
    Hi Rob,

    Thanks for the info. I will download the hotfixes and see if they give
    me the same issues.

    If you are not seeing the dbExpressSession option at design-time in the
    Delphi object inspector, it is likely not installed into the IDE. Open
    the Components | Install Packages... option of the IDE and look for the
    entry "ReportBuilder Data Access for dbExpress". If this is missing or
    unchecked, re-check it or add the \RBuilder\Lib\dclRBDBE1215.bpl to the
    list.

    If this gives you errors, you may need to rebuild this package using the
    Source directory. Note that not having this package installed into the
    IDE only affects your app at design-time. Everything should still work
    at runtime.


    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited May 2011
    Nico Cizik (Digital Metaphors) wrote:


    It was missing.

    I added it, set the SessionType in the IDE to dbExpressSession, and the
    app now compiles and runs reports just fine.

    Sincere thanks for your help Nico - excellent support :-)

    Rob
This discussion has been closed.