New Blog Post: PDF/A and Metadata

ASTA and Report Explorer RB6.03

edited September 2002 in End User
Hi,

I am using the ASTA(2.6) DADE with Microsoft SQL Server 7/2000 and Delphi 5
Report Builder 6.03. The designer and dataviews work perfectly. I have now
tried to add the Report Explorer to the project to allow my customers to
store their reports in a SQL table. I used the Borland datapump to create
empty Item and Folder tables from the example Paradox tables. I have added
astaclientdatasets for the explorer tables and setup the editmode so the
tables can be updated. I then setup the datapipelines for these datasets and
linked them to the explorer component. However whenever I try and show the
Report Explorer window I receive a runtime 'Invalid Variant type conversion'
error. This seems to be coming from the ppExpFrm unit line 1527 - lItems :=
trvFolders.Items;.

Has anyone any idea why I get this error, what am I doing wrong. Has anyone
got ASTA with SQL Server to work with the report explorer. Any help greatly
appreciated.

Regards

Simon Callcott

Comments

  • edited September 2002
    Can you run the end user solution on your tables without using ASTA? This
    would be the first step to make sure that the table definitions are correct.

    Are you using the demo version of ASTA? I experienced similiar issues with
    this when running the demo version. The auto incremented field value wan't
    coming back after adding a new record in the folder/item tables from the
    client side. As soon as I installed the full version, it worked. We have run
    ASTA using the end user solution without problem like this.

    Cheers,

    Jim Bennett
    Digital Metaphors

  • edited September 2002
    Thanks for your reply,

    You were absolutely correct I had not set asta to refetch the autoincrement
    fields. That has sorted the explorer Folder creation. However when I try and
    save a new report back to the explorer Asta throws an error saying it is not
    connected to the server. The reports run correctly so Asta must still be
    active but I just cant save it. Any ideas please?

    Thanks

    Simon Callcott

  • edited September 2002
    Giving the explorer datasets their own socket connection seems to have
    solved that problem and it is now working successfully. However I am still
    having odd exceptions when I try to open a report I have just saved without
    changing record in the explorer, ie if I try to reopen a saved report when
    its the currently selected item in the explorer I receive an already open
    exception. Changing the current folder and then back to the report seems to
    stop this but how can I get this to work without doing this?

    Regards

    Simon Callcott
  • edited September 2002
    Were you able to run the RBASTA end user demo that is available from ASTA?
    It is the full end user demo setup and ready to go using ASTA, including a
    DADE plugin. We've tested it with ASTA 2.6 and RB 6.03 in Delphi 6 and it
    works.


    Cheers,

    Jim Bennett
    Digital Metaphors

This discussion has been closed.