Error when using ITE

edited June 2016 in General
Hi,

We are using Delphi XE2 and RB 15.03 and we trying to use ITE to
translate our app to Spanish. All is working fine, but when I try to
preview any report, I get the following error: "Resource TppPrintPreview
not found.", and I could not find how or where can I add RB dfm's.

Thanks,

Weverton

Comments

  • edited June 2016
    Hi Weverton,

    The TppPrintPreview class is located in the ppPrvDlg.pas file (rbRCL
    package).

    Note that many of the caption strings in ReportBuilder are already
    translated by our built-in localization architecture which is processed
    at runtime.

    See the languages section of the developer's guide as well as the
    ReadMe.doc file in the \RBuilder\Languages\... directory for more
    information.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited June 2016
    Hi,

    But, our major concern is about to make the core businness app works
    normally. The RB translation is not necessary for now. Do you know how
    can we do this?? We have already tryied to copy ppPrvDlg.dfm to out ITE
    project directory add we added it to the project, but the error still
    ocours.

    Em 13/06/2016 17:59, Nico Cizik (Digital Metaphors) escreveu:
  • edited June 2016
    Hi Weverton,

    I am unclear about the details of the error you are getting. If Delphi
    has access to the preview form resources (.pas and .dfm files) it should
    not be giving an error that it cannot find them. Check your library
    path to be sure Delphi is able to access these files.

    We do not have any experience with ITE.

    If this is an ITE error, you may need to contact their support for how
    to resolve it.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited June 2016
    Hi,

    Trying to solve the problem, I added some files from RB source folder to
    my project (ppPDlg.pas and ppPrvDlg.pas, for now). Now, ITE is creating
    the files from RB, but when I preview a report, all label captions come
    empty, so as in the print dialog. Is there a way to integrate force RB
    to load label captions from a specific language??

    Em 15/06/2016 11:38, Nico Cizik (Digital Metaphors) escreveu:
  • edited June 2016
    Hi Weverton,

    We have tried this here with the Delphi Translation Tool (ITE) and got
    the same behavior. Looking on-line at tutorials and articles does not
    seem to help find a resolution. According to all documentation, simply
    adding the .dfm files to the project and setting the correct language
    should allow them to be translated.

    Perhaps someone with ITE experience can chime in with their insight.

    As I mentioned before, we do not specifically support ITE and are not
    experienced with the feature. ReportBuilder includes built-in language
    features which should be used for translations.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited June 2016
    Hi Nico,

    Thanks for you attention e I'm sorry by delay in my response.

    Is there a way to force RB to load a specific language at runtime??

    Em 22/06/2016 10:17, Nico Cizik (Digital Metaphors) escreveu:
  • edited June 2016
    Hi Weverton,

    Yes, you can use the Report.LanguageID property to load separate
    languages at runtime. The default language resource is included with
    your .exe. All other languages need to be deployed with your
    application. These language files can be found in the
    \RBuilder\Languages\ directory. See the documentation in the same
    directory for more information.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
This discussion has been closed.