New Blog Post: PDF/A and Metadata

Missing Labels on Nested Subreports

edited August 2011 in Subreports
I am creating a report that needs to have, within each detail section of
the main report, two columns of data from two different data sources.
Like this:

Item X
Location CountA CountB
Loc1 1A 1B
Loc2 2A 2B
Loc3 3A
Loc4 4B

I have accomplished this with nested subreports. "Location" comes from a
DBPipeline that includes all locations for a given item (Item is the group
in the main report). The Location subreport is grouped on location with
the two counts as 2 inch wide subreports in the group band. CountA and
CountB are 2 more pipelines, with Location as their MasterPipeline, linked
by a location field. As you can see from my example, sometimes there may
not be a count for a given location in one or the other sub reports.

This is working nicely except for one problem. When there is no data for
a given location in the CountA dataset (see the Loc4 line in my example),
the Location label (which is a DBLabel in the Location report) appears
blank. The cooresponding CountB Data is displayed properly, and the
location itself shows up in the report outline when previewed, but it
isn't actually printed on the report. The location show up when there is
CountA data, but no CountB data, and when there is data in both sub
reports. It simply appears blank if CountA is blank. (so in the example
above, "Loc4" would not display, but there is blank space there and "4B"
is properly displayed).

I have tried different "NoDataBehavior" settings for the subreports, made
sure none of the data elements overlap, etc, but I have had no luck
getting that label to display.

Has anyone had this issue? Any idea how to fix it?




--- posted by geoForum on http://www.newswhat.com

Comments

  • edited August 2011
    Hi Kimberly,

    The Pipeline.SkipWhenNoRecords property controls whether the master
    record will display if no details are present. If you would like to see
    the master record even if there are no details, you need to be sure this
    property is set to False for all Detail datapipelines. I believe by
    default it is set to True.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited August 2011
    Hi Kimberly,

    If the SkipWhenNoRecords property of the Detail pipelines is set to
    False and the Master record is still not displaying, there must be
    something else going on. Which version of ReportBuilder and Delphi are
    you using? What database and connectivity are you using?

    If you would like, you can send me a simple example of this behavior in
    .zip format to support@digital-metaphors.com and I'll take a look at it
    for you.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited August 2011
    I changed that value to "False", but it did not help. I gave up and
    formatted the report differently, but I would still love to hear any other
    ideas as to what might be going on here.

    Thanks,
    Kimberly



    --- posted by geoForum on http://www.newswhat.com
This discussion has been closed.