New Blog Post: PDF/A and Metadata

F2051 Unit ppSMTPIndy10 was compiled with a different version of IdAttachmentFile.TIdAttachmentFile

edited February 2010 in General
I have updated Indy in Delphi 2009 and now trying to compile an application
using module ppSMTPIndy10 in Reportbuilder Standard Edition 11.07 build 2.
Receiving the fatal message noted in the subject when compiling. Indy went
from V10.2.5 to V10.5.5 to resolve an email attachment issue I was having
in another application.

Any thoughts would be appreciated. I am thinking I have to recompile and
reinstall reportbuilder but I thought I'd see if anyone has other
suggestions or instructions on how to handle this situation before I did
that.

Thanks,
Peter.

Comments

  • edited February 2010
    Hi Peter,

    You most likely do not need to re-install ReportBuilder. The error is due
    to the ppSMTPIndy10.dcu file in your library path not being compiled with
    the latest Indy source files. Try changing your library path to
    \RBuilde\Source\ and recompile (making sure there is not a ppSMTPIndy10.dcu
    file already present. Then you can copy the newly created .dcu file to the
    \Lib directory and change your library path back.

    --
    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited February 2010
    The error is gone after I moved the ppSMTPIndy10.pas file from the source to
    the Lib folder below ...\6.0\RBuilder. If anyone has thoughts on whether or
    not this is the correct approach, please let me know. It seems to be
    working.

    Thanks,
    Peter.

This discussion has been closed.