Preview hangs on loading archivereader

edited November 2017 in General
Hi,

we are reading an archived report from disk in order to display it on a
preview window.
Some customers report, that the report is displayed correctly but the
cursor keep a hourglass and previewwindow cannot be used, our software
has to be killed by processmanager.
The code is:

frmListePreview1.ppViewer1.Report := frmListePreview1.ppArchiveReader1;
frmListePreview1.ppArchiveReader1.ArchiveFileName := DataFile;
frmListePreview1.ppArchiveReader1.PrintToDevices;
frmListePreview1.ShowModal;

Could there be a threading problem between loading and displaying?
Something with the tppPublisher-Object?

--


Hint: We altered the sources!Hint: We altered the sources!

Comments

  • edited November 2017
    Hi Carsten,

    Yes this could very well be a threading issue. To find out, try setting
    the SinglePageOnly property (of the PreviewFormSettings or TppViewer) to
    True and see if it solves the problem.

    If this is the problem, we will need an example of this we can run here
    in order to track down and fix the issue.

    --
    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited December 2017
    Hi Nico,

    setting "ppViewer1.SinglePageOnly:=true" did not solve the issue, it
    even caused an EAccessviolation in ppDrawInfo.pas, 1077 on drawing a
    Jpeg-Image.

    Any other ideas?


    Nico Cizik (Digital Metaphors) schrieb :

    --


    Hint: We altered the sources!Hint: We altered the sources!
  • edited December 2017
    Hi Carsten,

    If you still get the error when setting SinglePageOnly to True, it is
    likely not a threading issue. Does this occur with every archive or
    just certain archives?

    Please create a simple example demonstrating the issue and send it to us
    in .zip format so we can research what is happening.

    --
    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited December 2017
    I am trying to reproduce it reularly, but i could not do it.

    Someitmes a report works, sometimes it fails.

    Could it be an issue with a virus-scanner?
    File is stored from database into a temporary file for loading into
    reportbuilder. Maybe any virus-scanner keeps its hand onit and
    interrupts loading .......

    Tia Carsten


    Nico Cizik (Digital Metaphors) hatte die Idee :

    --


    Hint: We altered the sources!Hint: We altered the sources!
  • edited December 2017
    Hi Carsten,

    We have not heard of a virus scanner causing an issue like this however
    an easy way to check would be to disable all virus scanning and security
    apps and see if you can recreate the issue.

    Unfortunately if we are unable to see the issue here with an example,
    there is little chance we can find out exactly what is happening.

    --
    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
This discussion has been closed.