Black box printed instead of image (RB 6)

edited March 8 in General

First of all I know that we are outdated 😊 but we still need to develop one project in Delphi 5 and ReportBuilder version 6…
So.. We have implemented the QR code in application, but now we have printing problems. Sometimes (not always) at some our clients (not all) printer prints black box instead of QR code (image). Then customer reopen application and printout under the same conditions works fine..
Sometimes it happens when printing one page sometimes when printing multiple pages..

The printers at the clients where this is happening are different (hp, canon, brother, etc. - lasers, inkjets, MFCs) with different types of drivers (PCL, PCL6, ...)

Its problem our application? Or Delphi5 + ReportBuilder 6? Or printer?

Any suggestion how to debug? :/

sry for bad english.




  • Hi Davor,

    Please consider updating your version of ReportBuilder and Delphi. Moving forward, you will not be able to sustain your project with such outdated tools.

    The black box issue was common with earlier versions of ReportBuilder. It was addressed in later releases. We provide the last released version for each Delphi version with a new license of ReportBuilder. In your case, we provide RB 7.04 for Delphi 5 (which I believe included a fix for this problem).

    If you are interested in purchasing a new license, please visit the following page:

    You might also try searching this forum for ideas on how to resolve the issue.
    Best Regards,

    Nico Cizik
    Digital Metaphors
  • This has happened to me with PostScript printers. The following setting fix it for me. Set the image as DirectDraw = True and ExportMetaFileasBitmap = True

Sign In or Register to comment.