EOLESysError on 64-bit server

edited September 2010 in Server
Our Report Server application was created using Delphi 6, RB Server 11.08.

The application has been installed in many sites successfully (as well as
many locally as well for testing different operating systems). However, one
client is having an issue on their Windows 2008 Server (64-bit).

We double-click the icon in the system tray to open the ReportBuilder
Services dialog, and click the Change button. As soon as we select our
report server EXE, we get the following errors:

Unable to register application as a COM Server: c:\etc\SSReportserver.exe

followed by:

Exception OLESysError in SSReportserver.exe. Error accessing the OLE
registry.

Do you have any ideas please as to why this might be failing to register?

Thanks,
Jason.
--
Jason Sweby
Software Development Manager,
Carval Computing Limited, Plymouth, UK

Payroll - HR - T&A - Access Control

Comments

  • edited September 2010
    I've since learnt that it is not exactly a Windows 2008 Server, but Windows
    Standard FE, which is also known as Small Business Server 2008.

    The user is an administrator.

    Jason.

  • edited September 2010
    Try exiting out of ReportBuilder Services (right mouse over the system tray
    icon and select Exit). Then re-start, but specify to 'run as Administrator'.

    On Windows 7 and Vista apps do not run with admin privileges unless you
    configure them to do so. I don't have Windows 2008 Server, but I'm guessing
    it has the new Windows security model.

    On my Windows 7 (32-bit) machine I can duplicate the error you receiving if
    I do not run RB Services as admin.


    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com



    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited September 2010
    Thanks Nard, I will give that a go and report back.

    Jason.

  • edited September 2010
    Hi Nard

    Our consultant had already tried that yesterday, says he got exactly the
    same error messages.

    Jason.

  • edited January 2011
    Hi Nard,

    This has now happened at a second customer today. Installing the
    ReportBuilder Services Service (that comes with RB Server 11.08) on a 64-bit
    Windows 2008 Server. The error messages received are identical to the ones I
    reported last September:

    Unable to register application as a COM Server: c:\etc\SSReportserver.exe

    followed by:

    Exception OLESysError in SSReportserver.exe. Error accessing the OLE
    registry.

    I cannot be the only person installing RB Services in a 64-bit environment?
    Has anyone got this working?

    Jason.

  • edited January 2011
    Has anyone got any news on 64-bit compatibility?

    Jason.

  • edited February 2011
    Hi Nard,

    This has now happened at a second customer today. Installing the
    ReportBuilder Services Service (that comes with RB Server 11.08) on a 64-bit
    Windows 2008 Server. The error messages received are identical to the ones I
    reported last September:

    Unable to register application as a COM Server: c:\etc\SSReportserver.exe

    followed by:

    Exception OLESysError in SSReportserver.exe. Error accessing the OLE
    registry.

    I cannot be the only person installing RB Services in a 64-bit environment?
    Has anyone got this working?

    Jason.

This discussion has been closed.