DADE and Parameter binding

edited March 2009 in Server
I've recently upgraded from RB Server 7.04 to 11.03. I went through your
new documentation and I really like a lot of the changes made. My current
report server uses all Delphi code (D7) and it runs quite nicely. But I was
contemplating changing all my reports to use DADE and RAP. So I started a
client project that does this with my existing SQL database. I've defined 2
parameters - those being startDate and endDate (obviously a dtDate
datatype). Then I built a dataview using the Query Wizard and I specified 2
autosearch settings that use the 2 parameters. I have "autosearch" set to
true and "mandatory" set to true. When I run the client program and call
the report's Print method, the autosearch dialog comes up and displays the
report beautifully. I can change start and end dates and it works great.
So, I took the datamodule containing the report and created a server project
with just that datamodule. I made sure my database component was thread
safe. I previewed the report from within the report designer and it worked
great. I clicked on the Search icon in the preview toolbar, changed the
start date and it worked as expected. I even threw a memo component on the
report that I added RAP code to the StartPage event of the report and
displayed report.autosearchfields[0].searchexpression and
report.autosearchfields[1].searchexpression. It appears in the preview
window as expected. When I run the server program and access the report
from a web browser, the report displays the autosearch dialog, but if I
click on the datetimepicker icon, I get a web page that displays a HTTP 403
error. Also, the report displays all dates within the tables that I'm
querying and no memo component. The parameters are not being read. Do I
need to use the tdaSqlBuilder to bind the autosearch values to the
parameters and the query dataview? I'm unable to find any tutorials that
use DADE and RAP in a server environment. I've read a lot of stuff on
rbWiki and your newsgroups, but I can't seem to find the answer.

Comments

  • edited March 2009


    I was able to recreate the error. The autosearch works for a field of type
    DateTime but for Date. There is now a patch available for RB 11.03. I
    emailed you the patch. Registered RB 11.03 Server Edition customers can
    email support@digital-metaphors.com and request the patch.

    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
This discussion has been closed.