Home End User
New Blog Post: Email: Multi-Service

Internationalization problem

Hello,
today I updated RB to th current version 21.04 on a VMWare VM with Windows11.
I installed all languages but set english as default.
In my application, I set the LanguageID on the PPReport component to German.
At designtime the language is handled properly, the 'page of' systemvariable displays in german 'Seite x von x'.
At runtime the english text is displayed (Page x of x).
When I open the reportdesigner at runtime, I set languageID also to german.
But it is not honored, both reportdesigner menus as well as the created report speaks english.
I copied all files from the reportbuilder languagedirectory (deu) to the application directory - nothing happens.
Then I tried copying them to the Windows\system32 directory but windows prevents it, even as administrator.
What do I have to do to make the report show and print in german ?

Regards Gerhard Sachs

Comments

  • Hi Gerhard,

    In my quick testing with RB 21.04, the german translation is working as expected at design time and runtime. Are you loading templates? If so, be sure you are setting the LanguageID after the template is loaded or the value will be overwritten by the template definition.

    Note that if you are on a 64 bit machine, you will want to copy the language .dll files to your SysWOW64 directory.


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
Sign In or Register to comment.