Home Component Writing
New Blog Post: Email: Multi-Service

Teechart 7 support

edited April 2004 in Component Writing
Hi,

Recently we ran an update of our Teechart installation and since then I'm
having trouble compiling my report builder projects. I had Report Builder
Server 7.03 for Delphi 6 with Teechart support, but now I get the error

"Unit Chart was compiled with a different version of System.RTLVersion"

when I compile my project.

I looked it up on the Steema website and I found that it's probably due to
the fact that my Report Builder version doesn't support this version of
Teechart (7 for Delphi 6). Do you have a version of Report Builder Server
that does support Teechart 7 for Delphi 6? Where can we download it?

Bram Boogaard, Eco Systems
b.boogaard@ecosystems.nl

Comments

  • edited April 2004

    RB 7.03 is compiled to support TeeChart 6.

    We currently have packages available for Delphi 7, RB 7.03, and TeeChart 7.
    You might be able to adapt these packages for RB 7.03 for Delphi 6. You can
    email support@digital-metaphors.com and request these packages.

    With Steemas Delphi 6 support for TeeChart 6 there are 3 different versions:
    - Delphi 6
    - Delphi 6 with rtl update 2
    - Delphi 6 with rtl update 3

    ReportBuilder for Delphi 6 requires rtl update 2. Do you know whether there
    is a TeeChart 7 available for D6 update 2? If so then that is the one that
    you should install.

    We will contact Steema and try to find out more details.....


    --
    Nard Moseley
    Digital Metaphors
    http://www.digital-metaphors.com



    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
This discussion has been closed.