Home Datapipelines

Application using JITPipeLine no longer works

edited May 2012 in Datapipelines
I wrote a sample application for hcOPF
(http://www.tpersistent.com/?page_id=44) about 5 years ago using Delphi
7 with RB10.4. I recently updated the application to use the current
version of hcOPF. This involved changes in UI binding primarily, and I
downloaded a trial version of RB Enterprise so I could test the
reporting. The reporting using a TppCustomDataPipeline which reports
directly from the objects in memory. I only had to modify the BookMark
related methods to use NativeInt, but for some reason the invoice report
returns 'No Data' even though the pipelines (master-detail) both have 1

Since I don't have source code, I cannot debug this any further, and
posting the app here would require the hcOPF framework to be downloaded
and compiled, as well as an Interbase database created and populated.

Any ideas?


  • edited May 2012

    You might try some simple base line tests.

    Create a new project and test the custom pipeline, without the master/detail
    setup and without the report. Just connect the custom pipeline to your data
    and then call methods on it. Open, First, Next, GetFieldValue, GetBookmark,
    GotoBookmark etc. You have the source code to the custom datapipeline so
    you can trace that code in the debugger.

    A no data condition means the DataPipeline.Bof and Eof are both returning

    Next incremental test, try connecting a report to the datapipeline above and
    then trace the custom datapipeline methods.

    The latest versions of Delphi include a free edition of CodeSite, so one
    debugging approach would be to add CodeSite logging messages to custom
    datapipeline code. Use $IFDEF's so you can turn them on/off as needed.

    We offer a 30-day money back guarantee on our products, so another option is
    to purchase the RB 14 upgrade so you have the source.

    Nard Moseley
    Digital Metaphors

    Best regards,

    Nard Moseley
    Digital Metaphors
  • edited May 2012
    Thanks for the suggestions....solved the problem.

This discussion has been closed.