New Blog Post: PDF/A and Metadata

Call to TrsWebRequest fails with "Invalid session"

edited July 2014 in Server
Hello,

I am having a problem handling my webrequest for a report.

In short my code:

var
s: TStringList;
req: TrsWebRequest;

begin
s := TStringlist.create;
try
req := rsWebTier.CreateWebRequest(s, '');
try
// Fill content parameters;
req.ContentParameters["name"].Asstring := "val";

// Fill sessionparameters;
req.SessionParameters['rosession'].asstring := sessionid;
if (rsWebTier.RequiresAutoSearchParameters(Req)) then
begin
**********************
Exception is thrown: Invalid Session!!!!!!
end;
finally
req.free;
end;
finally
s.Free;
end;
end;




I think the error has something to do with tye
SessionParameters['rosession'].

Wat code do I need to use to setup an valid session?

Thanks André Konijnendijk.

Comments

  • edited July 2014
    Hi André,

    Check out the RB Server custom parameters demos. They contains examples of
    performing custom processing.


    http://www.digital-metaphors.com/rbWiki/Server/Fundamentals/Custom_Parameter_Demos



    Best regards,

    -
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited July 2014
    Hi Nard,

    I have looked into your examples, but everything looks fine by me in
    our code.

    I will try to explain what the problem is.
    In the attachment you will find a few screenshots from my report
    definition.

    The report contains 4 linked tables and a seperate one.
    A parameter "verlofregelingen" is defined.
    When a LookupList is filled and no LookupSettings are defined, the
    autosearch screen is shown within the webclient.

    When the Lookupsettings are linked to the seperate datapipeline, the
    webclient aborts with a message "Invalid Session"

    Is there a parameter I need to set in the report?

    Thanks for the advice.

    André Konijnendijk.
  • edited July 2014
    Hi André,

    Attachments can be emailed to support@, please do not post any attachments
    to the newsgroups.

    Please create a simple example that I can build and run here and email to
    support@ in zip format. Perhaps use one of the demos as a starting point for
    your example.



    Best regards,

    -
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
This discussion has been closed.