New Blog Post: PDF/A and Metadata

Output to RTF skipping currency values

edited March 1 in Devices
When exporting to RTF a currency symbol on the report template causes
then rest of any text on a line to be skipped in the export.

This happens regardless of which type of component is used eg a
DBLabel or a RichEdit box with data merging.

Even just a label wth static text does not show the currency symbol or
anything after that line.

The same rtm file printed or previewed to screen shows the currency
symbol

However if I add a space to the currency symbol then it is exported
along with the rest of the line.

I have tried adjusting the RTF settings eg UseTextBoxes and it makes
no difference.

Comments

  • edited March 1
    Sorry forgot to say - Delphi XE2 and RB 18.01

    On Thu, 01 Mar 2018 13:37:17 +0000, Rhonda Ridge
  • edited March 1
    Hi Rhonda,

    This is not a known issue. As a quick test I created a simple report
    with 6 labels. All 6 labels exported to RTF (using text boxes and
    without) correctly.

    Label1: '$100.00'
    Label2: ' $100.00'
    Label3: '£100.00'
    Label4: ' £100.00'
    Label5: '€100.00'
    Label6: ' €100.00'

    Please create a simple example that demonstrates this issue and send it
    to support@digital-metaphors.com in .zip format so we can research it
    further.

    --
    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited March 5
    An issue with another component was muddying the waters so on further
    investigation ourselves we have pinpointed the issue more precisely.

    The problem only occurs under these specific conditions

    1. Mail merged or data fields that refer to a data pipeline
    (TppDBPipeline) in the calling application (a dataset created within
    the report on the Data tab works fine)

    2. Exported using :-
    ShowPrintDialog := False;
    AllowPrintToFile := True;
    TextFielName := 'email.rtf';
    DeviceType := dtRTF;
    Print;

    No other properties of TppReport are changed in code


    If your are in the RB Designer on the exact same rtm file and do Print
    to File manually from the menu the RTF file export is correct with
    symbol and value in the file as expected.


    A Preview always shows the currency symbol and value as expected.


    I wonder if you can reproduce the problem with this information?



    On Thu, 1 Mar 2018 09:12:42 -0700, "Nico Cizik (Digital Metaphors)"
  • edited March 5
    Hi Rhonda,

    I created a minimal example using your specifications but was still
    unable to recreate this issue.

    Please create a simple example that demonstrates this issue and send it
    to support@digital-metaphors.com in .zip format so we can research it
    further.

    --
    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited March 6
    As I can get around the problem I'll do that for now and will send you
    a sample project when I have time to create one.

    Thanks for looking into it.

    Rhonda Ridge





    On Mon, 5 Mar 2018 14:45:44 -0700, "Nico Cizik (Digital Metaphors)"
This discussion has been closed.