Delphi Rio x RB 20 Build 255 errors

Hello.

I migrated from RB 19 to 20 in Delphi Rio (10.3.2) and I have some errors.

When I change the caption of a Label directly in the report and hit enter, it generates an access violation reporting an error in the rblDE2026.bpl file. But this file doesn't even exist on my computer.

Another mistake is when I will include fields in my pipiline. Generates error "stantement's size limit is invalid"

How could you fix these problems?

Comments

  • Hi Ueliton,

    There is a patch available for the first issue. I sent this to your email address.

    The second issue appears to be a DB error. Which database and connectivity are you using for your application? During a quick Google search, this error could be a Sybase DB error indicating that your SQL statement is larger than the defined limit.


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • I use Sybase really.

    Connecting with FireDAC.

    I made a report using only 1 table and selecting only 1 field of the integer type from that table and the error persists.

    Even a small SQL of one field only gives me the same error.
  • Include the unit in the reported locations but the problem continues.
  • I think I found the problem of field selection.

    I enabled FireDAC trace.

    When saving the query I changed in ReportBuilder, you are running SQL below.


    235449530001 14:00:58.124 << Define(TFDDatSManager) [ADatSManager="Manager", ATable="<nil>", Command="SELECT TOP 0 PlanoContas.CodConta
    FROM PlanoContas PlanoContas


    Select top 0 in Sybase returns error Statement's size limit is invalid

    Sybase does not allow TOP 0

    It was version 19 and it worked, in version 20 it started to generate this error.

    Any suggestion?
  • Hi Ueliton,

    Are you using Sybase ASE or ASA? Which Sybase version?

    These links indicate that Select Top is supported

    https://razorsql.com/articles/sybase_limit_query.html

    http://dcx.sybase.com/1201/en/dbusage/first-order-formatting.html

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited September 2019
    cancelado
  • I use Sybase ASA 16

    Select Top 0 generates error.

    Including dbISQL (app running SQL's for Sybase tests)

    Select Top 1 OK

    Select First, OK. also works.
  • Returning error Statement's size limit is invalid

    The help below for this error states that the top must be a value greater than 0

    http://dcx.sap.com/index.html#sa160/en/saerrors/errm674.html
  • Hello, any answers to this select top 0 issue or version release for this issue?
  • Hello, any answers to this select top 0 issue or version release for this issue?

    My clients are experiencing this issue when editing their reports.
  • Hello.

    My boss and my clients are charging a fix date for this issue with Sybase.

    Is there any prediction for correction?

    Or a solution to this problem by changing some unit?

    Thanks
    Ueliton
Sign In or Register to comment.