Missing images when opening a report from archive after update of ReportBuilder.

After an update of ReportBuilder to 18.1, and simultaneous update of Rad Studio (Delphi) to 10.1,
all images (bmp and jpg) are missing from one, and only one, of my applications. I then updated to ReportBuilder 20.0, but that didn't help. I have tried to delete and recreate all the components involved (TppDBArchiveReader, TppDBPipeline and the datasets and the datasets and datasource). I have also deleted and recreated all DCU files, but nothing seems to help. It does not matter whether I open a document in preview (screen), print it to printer or save it to file as PDF. The images is always missing. This happens with all the documents in the archive, and only from one application. If I open the same document in an other application (also updated in the same way), or if I create a new test application with exactly the same components and code, it works perfectly.
I have tried all I can think of, and I am very grateful of any tips or Idea of how I can fix this.

Comments

  • Hi Trond,

    Generally when we see this behavior, it's due to the original Archive/Report being created with a third party image component such as DevExpress or GraphicEx. Then, if you update ReportBuilder and Delphi, this library is no longer present or referenced in the application.

    1. What type of images are you using? (png, jpeg, etc.).
    2. Is your application using any image components other than those provided with Delphi?


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • Hi, Thanks for the replay.
    1. We are using jpeg and bitmap images, and only ReportBuilder logo (TppImage). We import images either by selecting an image when designing the report or in code (Delphi) with TppImage.Picture.LoadFromFile methode.
    2. We are, in other project, using Envision Image Library from Interval Software, but it is only used to scan documents. This library is not included in the project (application) that produces the reports in the archive.

    However, by adding the unit “EnImgScr” from the Envision Library in the mainform, the images reappeared in the reports when open them in preview from the archive.
    I'm not sure if the Envision library is needed to view the images, since this library is not used in the application that generates the documents, but rather includes other libraries needed to view the images. It would have been nice to know if the Envision library is necessary or not to display the images, but I'm happy that it works again.

    Best regards.
Sign In or Register to comment.