New Blog Post: RESTful Reporting

ReportBuilder v20.01 Installation fails in Embarcadero RIO 10.3.0

I have a problem installing ReportBuilder 20.01 in RIO 10.3.0. After installation, RIO 10.3 fails to load ReportBuilder BPL files. The error I got is: “The procedure entry point @System@Classes@TFieldCache@$bcctr$qqrv could not be located in dynamic link library …\dclRBP2026.bpl”
The same also applies to ..\SYSTEM32\rbIDE2026.bpl ..\SYSTEM32\rbDB2026.bpl ..\SYSTEM32\rbCT2026.bpl ..\SYSTEM32\rbBDE2026.bpl ..\SYSTEM32\rbRTL2026.bpl ..\SYSTEM32\rbCIDE2026.bpl ..\SYSTEM32\rbUSER2026.bpl and several more bpl files.

In this forum I have found a discussion with heading: ReportBuilder v20 Installation fails in Tokyo 10.2. It says that only the latest version of Tokyo 10.2 is supported. Is it the same problem with RIO 10.3, that only the latest 10.3.3 is supported and not 10.3.0?

Comments

  • Hi Jonas,

    ReportBuilder 20.01 is built with Delphi 10.3.2 (Delphi 10.3 Update 2) but will function with Delphi 10.3.3. This is stated on the download link when downloading the product.

    It was our understanding that Embarcadero fixed a backward compatibility issue dealing with the error you are receiving but we later found they did not.

    We only have the resources to build and maintain versions of ReportBuilder with the latest release of each Delphi version. You will need to update to the latest version of Delphi in order to properly use RB 20.01.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
Sign In or Register to comment.