DOC device type and page footer

edited October 2010 in Devices
Hi,

I am using RB 12.2 enterprise with Delphi 2007. I have a report that has
a page footer consisting of a horizontal line, and two system variables
showing print date and page set.

This works fine when creating the report to screen, printer and PDF.
However, when I send the report to a DOC device type, the pagination is
messed up. The footer prints at the top of the following page and then
the next page's text gets pushed to a following page.

Any hope for making this work correctly?

Thanks,
Phil

Comments

  • edited October 2010
    Hi Phil,

    The DOC/RTF device attempts to convert precise report measurements to a text
    grid. This naturally can cause accuracy issues when exporting text
    intensive reports to RTF. Especially near the bottom of a page.

    My first suggestion would be to set the RTFSettings.UsePrecisionLines
    property to False. This by definition will decrease the vertical space used
    by the exported text at the expense of some minimal vertical accuracy.

    Also take a look at the following article on tips for exporting to RTF.
    http://www.digital-metaphors.com/rbWiki/Output/RTF/RTF_Fundamentals

    After this if you are still having issue with the DOC device, please send a
    simple example in .zip format to support@digital-metaphors.com and I'll take
    a look at it for you.

    --
    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited October 2010
    Hi Nico,

    I set UsePrecisionLines to false. This allowed the first page to print
    correctly, but subsequent pages still had the same problem of the footer
    printing on the following page.

    I will see if I can come up with a simple example.

    I really don't want to reduce the capabilities of the report (i.e. make
    it simpler) because I also want to be able to generate the same report
    as PDF, preview to screen and of course to printer. I was hoping the
    output would work consistently well no matter what device I used. My
    clients expect this sort of behavior.


    I upgraded to v 12 specifically and primarily because the information
    about v 12 says it now supports Doc export. Since this is listed in
    addition to RTF output, I assumed it would be better than RTF export -
    which I already knew didn't handle many of my reports well. To learn
    that it is RTF export under a different name was disheartening. I saw in
    a different post another client asking about full Word Doc export
    capabilities. That would be a tremendous help to my applications.

    Regards,
    Phil



  • edited October 2010
    Hi Phil,

    The fact that you are still seeing text overflow after setting the
    UsePrecisionLines to False means that there is an problem with the device.
    I will research and fix it once I receive your example and get back to you
    as soon as possible.

    Using the RTF format is not a "downgrade" from using the DOC format. The
    RTF version used (1.7) supports virtually every feature that can be used in
    MS Word. The spacing issues you are seeing would also exist in a native DOC
    format as well.

    The issue is that we are exporting a report that is designed with exact
    coordinate locations (down to the micron) to a text format that measures and
    spaces text based on font height and character space. It would be the same
    as if someone were to try to manually recreate a report inside Word simply
    using the key and key to control vertical and horizontal
    spacing.

    --
    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited October 2010
    Nico Cizik (Digital Metaphors) wrote:

    Thanks for the additional explanation about the DOC/RTF device.

    I sent a sample file to the support email address.

    regards,
    Phil
This discussion has been closed.