New Blog Post: PDF/A and Metadata

Navigating the report during generation caused the report to freeze

edited November 2013 in Datapipelines
Hi,
i upgrade from 12.05 to 15.01.
I test my existing reports and i have encountered this problem :
navigating the report during generation caused the report to freeze
The report has a property PassSettings set to psTwoPass.
What can i do ?

Comments

  • edited November 2013
    Il 05/11/2013 14:32, Mauro Catellani ha scritto:

    Hi,
    I noticed that if i set property SinglePageOnly,
    the preview is more quickly and the problem when navigating the report
    during generation caused the report to freeze doesn't appear.
    I need to set this property in all my reports ?
    It's a workaround ?

    Thank in advance
  • edited November 2013
    Hi Mauro,

    Setting the SinglePageOnly property to True reverts to the old RB 12 and
    earlier viewer/screen device and disables multi-page view capabilities.

    Is this behavior occurring for all reports you try to preview? If
    possible, please send me an example I can run on my machine that
    demonstrates this behavior in .zip format and I'll take a look at it for
    you. Send the example to support@digital-metaphors.com.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited November 2013
    Il 05/11/2013 16:26, Nico Cizik (Digital Metaphors) ha scritto:

    Hi Nico,
    this behavior occurs for all reports in preview.
    To send you an example is more complicated, because I use a framework
    that create a pipeline at run-time. The owner of this framework is
    another company. However, I will ask them if it is possible to prepare
    an example of report.
    In the meantime it is sufficient to send the file rtm ?

    Best regards.
  • edited November 2013
    Hi Mauro,

    Are you using a registered version of ReportBuilder and Delphi or are
    you using a product with ReportBuilder built-in?

    We are going to need an example we can fully run here that demonstrates
    the issue in order to be able to trace and fix any problems like this.
    Please construct a simple example, perhaps using a subset of your data
    in a TClientDataset that recreates this issue and we'll take a look at
    it for you.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited December 2013
    Il 06/11/2013 16:14, Nico Cizik (Digital Metaphors) ha scritto:

    Hi Nico,
    after you have received the email about the availability of Release
    15.02, i installed and tried this.
    It seems that reported problem "Navigating the report during generation
    caused the report to freeze" has been solved.

    You fixed something about ?

    Best Regards
    Mauro Catellani
  • edited December 2013
    Il 15/12/2013 18:30, Mauro Catellani ha scritto:

    Hi Nico,
    sorry , unfortunately I tried the wrong report.
    Also with the 15:02, the problem remains that had encountered.
    As soon as possible to prepare a sample with some data as you suggested.

    Best Regards,
    Mauro Catellani
This discussion has been closed.