eMail via ArchiveReader

edited October 2010 in General
Hello everybody,
i load a archivefile in the archivereader and try to email it.
But i get the error: EFOpenError -> File C:\tmp\M1201A01_rg.pdf can not open

Here my code:
ppArchiveReader1.Reset;
ppArchiveReader1.ArchiveFileName := 'C:\tmp\M1201A01_rg.raf';
ppArchiveReader1.DeviceType := dtScreen;
ppArchiveReader1.EmailSettings.Clear;
ppArchiveReader1.EmailSettings.Enabled := True;
ppArchiveReader1.EmailSettings.FileName := 'C:\tmp\M1201A01_rg.pdf';
ppArchiveReader1.Print;

The preview works fine, but when i touch the email-button the error comes up.

What is going wrong.
I think, it is something wrong stored in the RAF-file??

Have somebody a idea?

Olaf

Using:
Delphi7
RB11

Comments

  • edited October 2010
    Hi Olaf,

    What error are you getting?

    Note that after you make a call to EmailSettings.Clear, you will need to
    re-set the PreviewInEmailClient property if you would like an Outlook window
    to pop up.

    ppArchiveReader1.EmailSettings.Clear;
    ppArchiveReader1.EmailSettings.PreviewInEmailClient := True;
    ...

    In my testing with the latest version of ReportBuilder I was able to
    successfully email an archive using the archive reader preview.

    --
    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited October 2010
    Hi Nico,

    The German-Error message comes up in the Delphi IDE:

    Debugger-Exception
    ---------------------------
    Im Projekt Email.exe ist eine Exception der Klasse EFOpenError aufgetreten. Meldung: 'Datei C:\tmp\M1201A01_rg.pdf kann nicht ge?ffnet werden. Das System kann die angegebene Datei nicht finden'. Prozess wurde angehalten. Mit Einzelne Anweisung oder Start fortsetzen.
    ---------------------------
    In english something like: "Can not open file C:\tmp\M1201A01_rg.pdf" "Can not find C:\tmp\M1201A01_rg.pdf"

    When i run the application without Delphi, it happens nothing when i press the email button in the preview -
    no error message.

    With
    "ppArchiveReader1.EmailSettings.PreviewInEmailClient := True;"
    in my code - nothing changed.

    I use RB11 - email will only work with RB12?

    You have made an patch - i read in the groups devices.
    (date 2010-06-10)
    Will that work fo my issue?

    Thanks, Olaf

  • edited October 2010
    Hi Olaf,

    Which exact version of ReportBuilder are you using? My first suggestion
    would be to upgrade to RB 11.08 and see if that solves the issue. If you
    would like, you can send a simple example that demonstrates this issue to
    support@digital-metaphors.com in .zip format and I can take a look at it for
    you.

    --
    Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited October 2010
    Hi Nico,

    i used 11.07.
    And now with 11.08 - it works.
    Thank you, Olaf
This discussion has been closed.