Strange problem when printing ... no print job is created

We have some customers reporting that reportbuilder after working some time in the software, starts to send prints to nirvana.

Now we see, that when this happens, the printer-settings has a "Save to File" and there is "PDF" selected. We have this screen when we're in preview and click to printer button on top.

Removing the checkmark "print to file" prints the report normal to printer but next time it is again checked. So user can't print normally. He must go in preview, click to printer button top left and remove the checkmark.

Only restart of software works a while ...

Is this a known bug or is there any setting for this we're not able to see?
Yusuf Zorlu
MicrotronX Bilişim Ticaret ve Sanayi Ltd. Şti.
www.microtronx.org

Comments

  • This setting is visible if we set "AllowPrintToFile" to true so the user can select print to file if he wants that, but the customers having the problem do not use that checkmark but it is checked sometime and does not let the user remove the checkmark ...
    Yusuf Zorlu
    MicrotronX Bilişim Ticaret ve Sanayi Ltd. Şti.
    www.microtronx.org
  • Hi Yusuf,

    Report.DeviceType specifies device used by Report.Print (screen, printer, PDF, ...)

    Report.AllowPrintToFile specifies whether Print dialog includes print to file options. (Report.Print displays print dialog when Report.ShowPrintDialog is True).

    There is also a Report.PrintToDevices, a more advanced method for generating reports directly to one or multiple devices. See RBuilder Help for details.

    If your app is displaying the Print dialog with PDF selected and Print To File checked, that is due to the Report.DeviceType property being set to PDF.



    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • Hi Nard,

    we have Report.ShowPrintDialog:=false and we're using the report.DeviceType:='printer' in all cases where the customer reported that the printjob was not generated, instead of printing reportbuilder has generated a pdf file as defined in preview/print window where the checkbox for savetofile is visible and checked, but no one sets this!

    We're creating a complete new tppreport for each printjob and doing a complete setup of all settings, allways the same + afterloadtemplate. Customers reports that this problem ocurrs after he has created the first PDF with reportbuilder. We're using following setup to create a pdf-file:

    Create new "Report" Component, setup properties ...
    Report.DeviceType:='PDF';
    Report.TextFileName:=vmyfilename
    Report.AllowPrintToFile := true;
    Report.ShowPrintDialog := false;
    Report.Print;

    Is there something within reportbuilder which sets the parameters in the Print dialog (where the checkmark for savetofile is located + filename). How can we access that checkmark? If we have a way to access the checkmark + the filename we can clear the checkmark and filename before we call report.print in such cases.

    At the moment we try to completely disable report.AllowPrintToFile ... but there are customers who need and use that option...
    Yusuf Zorlu
    MicrotronX Bilişim Ticaret ve Sanayi Ltd. Şti.
    www.microtronx.org
  • Hi Yusuf,

    There are no known issues with RB.

    I'm not clear, sounds complicated. You state 'we have Report.ShowPrintDialog=false' and later ask about how RB sets up the the print dialog? When ShowPrintDialog False, no print dialog is created.

    1. Have the user provide specific steps for you to recreate the issue.

    2. Perform testing and debugging of your application code.

    3. If you would like to create a simple minimal example project we can run it in the debugger. Please use standard Delphi components and RB. Send in zip format to support@




    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • Hi Nard, thats the problem. We have ShowPrintDialog = false but when the problem occurs and we go into PREVIEW and click to printer button (most top left) than the printdialog shows and there is the "Save to file" Checkmark + Filename in users profile-directory as report.pdf

    It works most of the time and 90% customerside without problems but on some systems the checkmark for "Save to file" within the invisible PrintDialog is checked.

    We are not able to recreate that on our side but it was possible for me to see that problem over teamviewer / remotehelp session on customer side. So yes, the problem is real but not seen on our machines.

    Possible that we are able to access that setting for the checkmark on code?
    Yusuf Zorlu
    MicrotronX Bilişim Ticaret ve Sanayi Ltd. Şti.
    www.microtronx.org
Sign In or Register to comment.