Home Server
New Blog Post: Email: Multi-Service

Expected date format in search fields

edited June 2017 in Server

We are using version 17.03. We install the report server and by
default it using the Local System account
We are trying to figure out how to influence the date format that is
used in search values and by default in the reports (if we do not
specify another date format)

1- In our previous installation (version 15.02) we could replace the
user account that the service was using and the regional date settings
of this account was used. This was convenient for our clients

2- We tried to do the same for version 17.03 but is seems that the
date format settings of this user are not used.

My questions are
1- Which account is used to obtain the date format settings that are
using in the search parameters and the report
2- Is it possible to change these settings in any way

Paul Sjoerdsma


  • edited June 2017

    I just fiddled around with changing the user account that runs the
    Report Server and changing the regional settings for different system

    I can change the display format for date values that are displayed in
    the search value box when I open a report from a browser by changing
    the regional settings for the local system account.
    However the expected date input format always seems to be
    month-day-year. Not sure where and how I can change this.

    Paul Sjoerdsma

    On Fri, 02 Jun 2017 10:47:15 +0200, Paul Sjoerdsma
  • edited June 2017
    Hi Paul,

    The WebTier app generates the html/javascript previewer. The Delphi
    FormatSettings specify the date format. These are initialized to the Window
    Regional Settings for the user account.

    A couple of options:

    1. Configure the Windows Regional Settings for the user account that hosts
    the WebTier app.


    2. Add code to the WebTier app to modify the Delphi FormatSettings at

    Best regards,

    Nard Moseley
    Digital Metaphors

    Best regards,

    Nard Moseley
    Digital Metaphors
This discussion has been closed.