Home Server

Regserver problem

edited October 2014 in Server
I have a couple of Report Builder servers running. On one of my servers, I
changed the name of the SQL Server database. I use an ODBC System DSN that
is defined for the new database. I wrote an Initialization program where
the user defines the DSN used to connect to the new database and the value
is written to the registry. My rbServer program has a unit called globals
that reads the registry key in it's initialization section. All of the
report datamodules assign the database alias in the OnCreate event. This
process has worked well for me for years. When I run the rbServer program
with no parameters, it works fine. But when I add the "regserver" parameter
and try to run it from the Report Builder Administrator, I get an error tone
from Windows. The program starts but errors out when trying to run a
report. Nothing is written to the rbserver log file or the webtier log
file. I'm totally lost as to why this would happen. I'm using Delphi7 with
Report Builder 11.07.

Gary H.

This email is free from viruses and malware because avast! Antivirus protection is active.
This discussion has been closed.