DATE FORMAT

edited October 2009 in Server
Hi.
I need some help. I've got two servers running the same webtier and the
same report which has a date field without especific format.
One of them shows that field with a "dd/mm/yyyy" format and the other
with a "mm/dd/yyyy" format. Both servers and IIS are confgured in the
same way obout country, language and regionalization.
What I need to know is what configuration is being read to assign the
format? because I need both servers showing the same format leaving the
field without a manual configuration but I can't find what I forgot to
configure in the server.
thanks

Comments

  • edited October 2009
    Access the Windows Regional settings for each machine and review the date
    format settings.

    Make sure you build the Server and WebTier using the latest release, RB
    11.06.

    Make sure you do not have code that overrides the Delphi globals such as
    ShortDateFormat.

    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited October 2009
    Thanks
    I've checked that but I'm using rbserver 9.03. That might be the problem?


    Nard Moseley (Digital Metaphors) escribió:
  • edited October 2009
    Yes. RB 11 includes enhancements to support the date locale of the webtier
    machine. There is also a nice a Calendar that is displayed to the user.

    http://www.digital-metaphors.com:8080/General/What's_New/RB_11



    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
This discussion has been closed.