Timeout

edited March 2009 in Server
Hi!

We are having trouble with timeout on one of our webreports. The error
'Timeout has expired' occurs after 30 seconds. I have used your demo
rbserver and webtier for webreports. All properties regarding timeout is set
to 600 seconds on both this applications and in webtier.ini. Timeout in
sql-sever is set to infinite, and IIS is set to 600. Any idea on how to fix
this problem?

Regards,
Terje

Comments

  • edited March 2009


    My guess is that you are using ADO. The TADOConnection.CommandTimeout
    property has a default value of 30 seconds. Try increasing that value.


    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited March 2009
    We have already tried that. The TADOConnection.CommandTimeout is set to 600.
    We have also set the individual TADOQuery.CommandTimeout to 600 on all
    querys.

    Regards, Terje



  • edited March 2009
    Check the following property values

    Server.TimeOut
    WebTier.ServerConnection.TimeOut
    WebTier.SessionOptions.SessionTimeOut



    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited March 2009
    We have already done that with no luck. Is it possible that your
    webreporting tool uses msxml3.dll? At one time we have encountered
    a access violation in this dll, and according to some webpages this dll can
    cause some timeout. Just a suggestion.

    Best regards,
    Terje




  • edited March 2009

    RBServer does not use msxml.

    As a test try running the windows client. Run the example installed to
    RBServer\Demos\Clients\Client Explorer. Configure the time out propert for
    the client report.

    This is a real mystery.




    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited March 2009
    Hi Nard,

    I have done that and set the timeout to different values. Even when i set it
    to 5 secs. it timed out on 30 secs. I guess the computerghost is after me. I
    have run out of options. I don't get a timeout if i run it from inside so it
    can't be the sql-server. Any other suggestions?

    Regards,
    Terje



This discussion has been closed.