Reports on webserver

edited February 2009 in Server
Hi there!

I have a reportserver and webtier.dll that works very well on my pc through
localhost. I have installed it on a webserver (II6) with exactly the same
setup, but i can't get it to work. The reportserver is set up as a service
and is running. Do you have a detailed description on how to set it up on a
webserver?

Best regards,
Terje

Comments

  • edited February 2009


    Here is an article about configuring the WebTier for IIS 6

    http://www.digital-metaphors.com/rbWiki/Server/Web_Tier/How_To...Deploy_to_IIS6

    and for IIS 7

    http://www.digital-metaphors.com/rbWiki/Server/Web_Tier/How_To...Deploy_to_IIS7


    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited February 2009
    Hello again!

    Nice. I have done that and it works. I now get my report explorer in the
    browser with the folders and files i have published. But, i get an error
    when i attempt to open a report. The error is "HTTP Error 401.1 -
    Unauthorized: Access is denied due to invalid credentials."

    What is likely to cause this error?

    Best regards,
    Terje



  • edited February 2009


    Security. IIS typically creates special user accounts. Those accounts need
    access to the rbWebPub folder and subfolders. The speciific account names
    may have changed for IIS 6, but the concepts explained here still apply.

    http://www.digital-metaphors.com/rbWiki/Server/Web_Tier/IIS_User_Accounts


    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited February 2009
    I have done all this and rebootedt the machine, but still get the same
    message. I have checked all the directories and
    they have 'allow all' on IWAM and IUSR. The ReportExplorer is shown in the
    browser with all reports but as soon
    as attempt to open a report the error occur. Any other ideas?

    Best regards,
    Terje



  • edited February 2009
    Try granting full controlto all users for the rbWebPub folder and its
    subfolders.

    Perhaps with IIS 6 is running the process under a different account.

    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/3648346f-e4f5-474b-86c7-5a86e85fa1ff.mspx?mfr=true




    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited March 2009
    Hi!


    Done that, same result. Below is my ini-file. Could this be the problem.
    When is the ini-file loaded for the web-tier? Does the webtier save to
    ini-file?
    How can i get webtier to reload ini-file?


    Best regards, Terje



    [WebTier]
    CacheDirectory=C:\ReportsDT\cache\
    WebCachePath=http://asp.boman.no/ReportsDT/Cache/
    WebModuleURI=http://asp.boman.no/ReportsDT/myWebTier.dll

    [GarbageCollection]
    MinSleep=60
    SeparateThread=1

    [LogSettings]
    Verbose=1
    EnableLogging=1
    Format=TextFile
    Location=($Application)\LogFiles

    [ServerConnection]
    Address=http://asp.boman.no
    Port=1333
    TimeOut=60

    [SessionSettings]
    SessionTimeout=300
    MaxReportCount=0

    [ViewerSettings]
    ToolbarOptions=31
    IncrementalMode=1
    IncludeOutline=1
    ZoomPercentage=70

    [Server Farm]
    Enabled=0
    ColorizedPages=0
    LoadBalancer=Round Robin
    LoadCheckInterval=30
  • edited March 2009

    1. The [ServerConnection] "Address=http://asp.boman.no" does not look
    correct. If the report server is running on the same machine as the webtier,
    set it to LocalHost. Otherwise use a static IP address.

    2. If you have the ISAPI.LL configured to run in High Isolated mode, then
    you use IIS Manager to unload it. Otherwise, you will need to stop IIS and
    restart it. That will unload the DLL and the next time it runs the .Ini will
    be reloaded.

    3. If you have firewall software, then open it for the server port and for
    port 80.


    --
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
  • edited March 2009
    We have fixed the problem. The problem was some stupid
    networkconfiguration, and probably the [ServerConnection].

    Thanks a lot for your effort.

    Best regards,
    Terje

This discussion has been closed.