New Blog Post: Email: Multi-Service

Missing tables in Query Builder

I'm using DBISAM 4. It is successfully installed, and I have several apps where DBISAM tables appear in the Data tab Query Builder. I have one app, however, where the Session Type, Database Name and Database Type are all correctly set but no tables appear. Nor is an error generated. This is an app that's being upgraded from earlier version of DBISAM as well as an earlier RB. Did I miss a property that's causing this behavior?


  • edited March 2021
    An update: since I could see no difference in the properties of the Report component, DBISAM Database or DBISAM Session in an app where it worked versus the one where it was not working, I finally just deleted the Session component and re-added it. I now see the tables in the RB Query Wizard and Query Builder.
  • Hi Frank,

    Generally the only reason tables or fields would be missing from the Query Designer (due to ReportBuilder) would be if a DataDictionary component was restricting them. Otherwise it would likely be an issue with the connectivity components (in your case DBISAM). As to why, I am unsure. It could have been corrupt connection settings, a certain property of the connection, or a bug of some sort.

    Nevertheless, removing and re-adding the session component was a good first step to see if the issue was with the connectivity. I'm glad it worked!

    Best Regards,

    Nico Cizik
    Digital Metaphors
Sign In or Register to comment.