Home Datapipelines
New Blog Post: Email: Multi-Service

Getting an error Cannot assign a TFieldList to a TStringList

Hi,
I am migarting my application from delphi 4 to 10.4. Currently I am using report builder 21.01.
In older version, delphi 4 when assigning datasorce to TppBDEPipeline its working fine. But after migartion in delphi 10.4 its giving an error "Cannot assign a TFieldList to a TStringList" on assigning datasource to TppBDEPipeline.

Code example:

var
FPipeLine : TppBDEPipeline;
begin
FPipeline.Datasource := DatasourceImprRapt;

Comments

  • Hi Rajeev,

    I'm a bit unclear about where the error is occurring. Assigning a TDatasource object should not cause a TStringList error. As a test, set your library path to \RBuilder\Source\ and trace further into the RB source to see where this error is happening.


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • Hi nico,
    As suggested we have added \RBuilder\Source\ path to our Delphi library path and after that we are facing issue which we have already discussed in the below link.
    https://www.digital-metaphors.com/forums/discussion/comment/51154#Comment_51154

    As per above link you have suggested us to install everything after cleanup. We did the same but still facing the issue while building our application. We have checked all the dependencies but could not found anything at our side. Please suggest us further on the same.


    Thanks
    Rajeev
  • Hi Rajeev,

    Please see my recent response to the referenced thread and respond with your findings.


    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited March 17
    Hi Nico,
    I have created one sample for above problem and attached here:
    https://github.com/rajeevgl31/stats

    Please let me know if you have any question or query.

    Thanks
    Rajeev
Sign In or Register to comment.