Issue printing Japanese date characters to PDF

edited April 2014 in Devices

I'm using Delphi 2007 with RB version 15.03 build 87. I have a very simple
project that just prints a header with the current date and time (using the
TFormatSettings version of FormatDateTime e.g.....

GetLocaleFormatSettings(LOCALE_SYSTEM_DEFAULT, l_FormatSettings);
MyppLabel.Caption := 'Date: ' + FormatDateTime(LongDateFormat, now,
l_FormatSettings) + ' - Time: ' + FormatDateTime(LongTimeFormat, now,

I have my windows configured so that the region settings point to a Japanese
System Locale. This reports previews to the screen fine and shows the
Japanese characters for day/month in the date, but when I create a PDF they
are not displayed correctly?

Any ideas please




  • edited April 2014
    Hi Willie,

    ReportBuilder does not support any Japanese ANSI code pages for PDF. In
    order to properly display Japanese text inside a PDF, you will need to
    use the Unicode encoding feature of the PDF device which requires a
    Unicode enabled version of Delphi (2009 or later).

    Best Regards,

    Nico Cizik
    Digital Metaphors
  • edited April 2014
    Thanks for the clarification Nico, there aren't any other renderer addins
    that would work with ReportBuilder? , I found one from Waler but it stopped
    at RB11.


  • edited April 2014
    Hi Willie,

    Waler ExtraDevices did not support Japanese ANSI code pages. You might
    research if Gnostice eDocEngine supports it.

    Another option would be to print to a PDF driver such as the one that is
    included with Acrobat. There are a number of free ones available on the

    The best option of course is to upgrade your version of Delphi so you
    can continue using the built-in and fully supported PDF device included
    with ReportBuilder.

    Best Regards,

    Nico Cizik
    Digital Metaphors
  • edited April 2014
    After posting my reply I found some links in the rbWiki, looks like the
    WPCubed works for my Japanese dates.

    Thanks Nico

This discussion has been closed.