Crosstab and page breaks in XLSReport

edited December 2013 in Devices
Delphi XE3, RB 14.08.

If I have a crosstab report that prints over several pages, the export to
XLSReport format includes 4 empty rows at each page break.

Is there a setting to change this (I couldn't find one), or is this an
issue?

User wants to use the XLSReport format instead of XLSData, so that isn't an
option.

Regards
Jason Sweby.

Comments

  • edited December 2013
    Hi Jason,

    Try setting the TppXLSSettings.IgnorePageHeight property to True. This
    prevents extra rows from being added to the bottom of the page to more
    closely represent the page height.

    Best Regards,

    Nico Cizik
    Digital Metaphors
    http://www.digital-metaphors.com
  • edited December 2013
    Hi Nico,

    Thanks for the response. I cannot find this property on the report's Object
    Inspector, is this new in v15 (we're currently on v14.08)? I also tried
    setting it in the RAP:

    procedure ReportBeforePrint;
    begin
    Report.XLSSettings.IgnorePageHeight := True;
    end;

    But the report compiler doesn't like it.

    Regards,
    Jason.

  • edited December 2013
    From the What's New for RB 15 feature list...

    - XLSReport.IgnorePageHeight property,
    when True prevent blank rows from being added to bottom of page

    Complete RB 15 feature list

    rbWiki

    http://www.digital-metaphors.com/rbWiki/General/What's_New/RB_15

    Web site

    http://digital-metaphors.com/company/news.html



    Best regards,

    -
    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com

    Best regards,

    Nard Moseley
    Digital Metaphors
    www.digital-metaphors.com
This discussion has been closed.