Home General

Unable to compile

edited June 2011 in General
I am running D2007 Enterprise with RB 12.04 Enterprise. I was having issues
with some Indy components so I downloaded and installed the latest build of
Indy, and removed the version that comes with Delphi. That my issue with
Indy. I also went into Tools > Options and changed the Library path From
RBuilder\Lib to RBuilder\Source.

I can get all of my apps to compile except for one. When I try to compile
this app I get the following error:
[DCC Error] Main.pas(100): F2051 Unit raParser was compiled with a different
version of ppRTTI.TraRTTIClassRegistry

I'm trying to determine if the problem is with a different third party
component or what. Any ideas or suggestions as to what to try to pin this
issue down?

Thanks in advance,
Rodger Van Kirk


  • edited June 2011
    I'm not sure if it would help but I just tried compiling one of our packages
    and it is also giving an error. This is a different error but figured I'd
    post it and see if it helps.
    [DCC Error] rbRTL1211.dpk(109): F1026 File not found: 'ppCollectionBase.dcu'

    Thanks again,
    Rodger Van Kirk

  • edited June 2011
    I think I solved this issue with the packages by putting the RBuilder\Lib
    path back into the library after the RBuilder\Source path. The packages
    seemed to compile now. Now if I can just figure out the other issue.

    Rodger Van Kirk

  • edited June 2011
    RB does not require Indy, but has SMTP plug-ins that can optionally be used
    to leverage Indy for sending email. The plug-ins are units called
    ppSMTPIndy9.pas and ppSMTPIndy10.pas. You might need to copy the applicable
    source unit to RBuilder\Lib and then modify your application you to use the
    appropriate unit. You do not need to recompile any source code other than
    the plug-in unit.

    Typically the compile error about a different version is due to one the

    1. You have modified the interface section of a unit that RAP 'uses'. (but
    RAP does not use Indy)

    2. You have one or more RB source units on your system that are from an old
    version of RB and the compiler is finding the unit.

    3. You are compiling the RB source with different compiler settings than we
    use (we use the default settings).

    Nard Moseley
    Digital Metaphors

    Best regards,

    Nard Moseley
    Digital Metaphors
This discussion has been closed.