PDF with passwords are not previewed in GMAIL

Hello, I write here from Brazil, and we have a problem where when we send a PDF file protected with a password, the recipients of GMail, when clicking on the attachment in the preview, and typing the password, are receiving a preview message saying that the password is wrong. They only succeed after downloading the PDF. In doing so, when entering the same password, the file is displayed. It seems that something has changed in GMail. It turns out that there are files from other applications that are not experiencing this problem, even in GMail. Comparing the properties of our file, generated by ReportBuilder and the file of the other application, I thought about changing the name property "PDF Producer" which for us is "ReportBuilder" and for them just "PDF". But I didn't find how to change that. Can you help us?
A hug.


  • Hello,

    There is now a patch available for ReportBuilder 20.03 that addresses this issue. Registered RB 20 users with a valid software subscription can email support@digital-metaphors.com to receive the patch.

    Best Regards,

    Nico Cizik
    Digital Metaphors
  • I will see the feasibility of this update and comment here Thanks.
  • Is there a 20.03 trial version? For confirmation which will resolve? Because the change here will be very big.
  • edited September 2020
    Hi Marcio,

    It appears GMail has a bug in the latest version. All other PDF readers work. We have researched and were able to create a patch for RB 20.03 that resolves the issue. Registered RB 20 users with a valid software subscription can email support@digital-metaphors.com to receive the patch.

    I recommend upgrading your RB license, then email support@ with registration info and serial number and request the patch. Going forward I recommend participating in the RB subscription.

    Best regards,

    Nard Moseley
    Digital Metaphors
  • edited September 2020
    Hello @nardmoseley and @MarcioTeresopolis

    I have the same issue with 16.02 version with a legacy app. It was very complicated to upgrade to RB 20 version. So I set EncryptSettings.Enabled:= false and after that the customers said the Gmail and Hotmail is not asking passwords anymore. I generate the pdf of my app via code not the RB UI.
    I hope I can help you.

    Regards, Rogério.
  • edited September 2020
    So just to confirm my doubts and if I can really cause this big change (because it would make a lot of changes in code to update all the components), because I need to get a confirmation of this problem being treated on the patch so I can upgrade to the last version. Could you provide the trial version with this patch so I can be sure or can you just provide a program (don't need to be the project, just the .exe of the delphi 7 program would be enough) that creates a PDF so I can test if this issue is really solved? I need one of those before doing any big change just so I can confirm that they will solve my current issue, because it would be useless to get a version now, adapt all the code I have, and then discover that the error still persists. I would be really glad if you could help me with that.
    Best Regards,
  • Thanks for confirming there is a patch: we were wondering if perhaps Google (gmail) had stopped supporting RC4 40 bit, but after trying RC4 128 bit and AES 128 bit which worked when creating PDFs directly from Acrobat, but not from Report Builder, realised it wasn't that.
  • I just wanted to follow up on this. We haven't had a chance to upgrade to 20.04 (or apply the v20 patch) but I just happened to re-test today and it seems that Google has fixed their bug: it now works fine through a browser and (at least some) phones have the fix now, as well.
Sign In or Register to comment.